Max, help Iam getting desperate with my C5 steering

C5 Specific - Technical and Performance

Moderators: DOC, MR.WOLF, australi, smackC4

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Max, help Iam getting desperate with my C5 steering

Postby Panther » Sat May 17, 2008 6:27 pm

Max
Can you check with GM supplier, I need the torsion shaft that goes into the gear that drives the steering rack, its hardened and has been removed to be put into our RHD rack, but as it has been pushed out its removing some of the burrs that help it bind into the original gear, and our gear is a little out so it just spins, I will find someone to re make the gear but I would prefeer to have a new shaft as well

Kim

User avatar
Winfield RED
*Gold Class Member #350
Posts: 5917
Joined: Fri Mar 03, 2006 1:37 am
Location: Just north of Brisbane, AUSTRALIA

Postby Winfield RED » Sat May 17, 2008 6:46 pm

Panther you might have to send him a PM as well mate, just incase he is busy he may not check the forum, but sending him a pm will give him an email :o

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Mon May 19, 2008 10:01 am

yeah Ta, I will

User avatar
Winfield RED
*Gold Class Member #350
Posts: 5917
Joined: Fri Mar 03, 2006 1:37 am
Location: Just north of Brisbane, AUSTRALIA

Postby Winfield RED » Mon May 19, 2008 5:17 pm

No worries chief, if i can manage to get onto him on the blower ill let him know youre after some gear :o

User avatar
MAXX WRENCH
*Gold Class Member #200
Posts: 1870
Joined: Fri May 05, 2006 5:29 pm
Location: COLORADO..USA

Postby MAXX WRENCH » Tue May 20, 2008 4:04 pm

SORRY SO LATE PANTHER...BEEN BUSY

YOU NEED THE STUB SHAFT THAT STICKS OUT OF THE GEAR OR DO U NEED THE INTERMEDIATE SHAFT THAT HAS THE CLAMP ON IT THAT ATTACHES TO THE SHAFT COMING OUT OF THE GEAR?
ONE SHOT ONE KILL I WIN

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Wed May 21, 2008 7:21 pm

sorry dont have a picture, its the one that goes into the gear and up through the magna steerm about 6" long, a hole one the top end and a spline on the end that goes into the gear, did that make sense

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Wed May 21, 2008 7:22 pm

or do you ahve a break down picture of the rack

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Thu May 22, 2008 9:22 am

MAX

found a pic in 99 service manual

Vol 1, section 2, page 181 and its called a SPOOL SHAFT

that may help you figure out what I need

Thanks
Kim

User avatar
MAXX WRENCH
*Gold Class Member #200
Posts: 1870
Joined: Fri May 05, 2006 5:29 pm
Location: COLORADO..USA

Postby MAXX WRENCH » Thu May 22, 2008 9:36 am

PANTHER...CHECK YOU PM BOX
ONE SHOT ONE KILL I WIN

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Thu May 22, 2008 4:27 pm

Yeah Donnie noted, thanks for your efforts as always.

Seems with the help of several guys down here we have it sorted, and correcting a stupid design by GM by going from a spline to a hex head design, should know late next week, its with the engineer now, I should of taken this problem on over a year ago, instead of waiting on the converter whos still at a lose what to do, I guess he will figure it out when he gets the invoice

User avatar
MAXX WRENCH
*Gold Class Member #200
Posts: 1870
Joined: Fri May 05, 2006 5:29 pm
Location: COLORADO..USA

Postby MAXX WRENCH » Thu May 22, 2008 5:15 pm

SORRY PANTHER :?
ONE SHOT ONE KILL I WIN

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Fri May 23, 2008 5:57 am

don't be sorry mate, as I beleive I have sorted it out in 2 days what the converter still hasn't been able to do in 13 months, Iam happy I can see some light in the end of the tunnel

Cheers guys

Will let you know how it all pans out in about a week

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Sat May 31, 2008 8:27 am

The steering gear is completed and I will have it back on Monday, cost me $300, so that part has been solved, just has to be assembled calabrated and installed, with no leaks, will report once done

User avatar
gtc
* VIP Forum User
Posts: 2683
Joined: Sun Nov 18, 2007 11:56 am
Location: Sydney, NSW, Australia

Postby gtc » Sat May 31, 2008 9:39 am

Good news after all of that waiting. :o

User avatar
MAXX WRENCH
*Gold Class Member #200
Posts: 1870
Joined: Fri May 05, 2006 5:29 pm
Location: COLORADO..USA

Postby MAXX WRENCH » Sun Jun 01, 2008 3:50 am

:D :D :D RIGHT ON PANTHER...GLAD TO HEAR IT...SORRY I COULDN'T HELP YA
ONE SHOT ONE KILL I WIN

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Sat Jun 07, 2008 8:36 am

don't be sorry mate, you tried where most would not of bothered, so thanks heaps.

What we had to do was machine out the hole for the shaft into a hex, machine off the splines of the shaft make up a interference hex sleeve and fit over the shaft and tap it in, bingo, well not really they also used a exoxy so when it was tapped in we found that it was 3mm to high, has just been corrected and should be back on Tuesday.

The shaft is also made of a unusual material that is extremly hard, learnt a lot as always, I should of taken this on some 10 months ago instaed of waiting for them to find a solution.

User avatar
australi
* Founding Administrator
Posts: 16532
Joined: Sun Jan 15, 2006 8:32 pm
Location: Brisbane, Queensland, AUSTRALIA
Contact:

Postby australi » Sat Jun 07, 2008 11:05 am

Sounds like 300 bucks well spent Kim! :o

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Tue Jun 10, 2008 12:36 pm

aint that the truth should have it back today, then back to the steering guy to assemble, could be seeing some tar soon

User avatar
australi
* Founding Administrator
Posts: 16532
Joined: Sun Jan 15, 2006 8:32 pm
Location: Brisbane, Queensland, AUSTRALIA
Contact:

Postby australi » Tue Jun 10, 2008 12:46 pm

Excellent. :-D

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Sat Jun 21, 2008 4:59 pm

anyways, fitted rack back into car today, I used a 2004 rack, well it didn't quite go to plan, what does, they have put the head at a different angle so the hydrolic Lines are the wrong shape and angle, and the rack is not centered, I like chinese, Iam sure I didn't run over one, if I did forgive me PLEASE

Anyway will work on that over the next week, as its Bourbon O Clock

User avatar
Winfield RED
*Gold Class Member #350
Posts: 5917
Joined: Fri Mar 03, 2006 1:37 am
Location: Just north of Brisbane, AUSTRALIA

Postby Winfield RED » Sat Jun 21, 2008 5:07 pm

I might join you with an Irish Whiskey Panther :D

User avatar
ernbuild
Gold Class Member #154
Posts: 1210
Joined: Mon Apr 03, 2006 6:05 pm
Location: Brisbane, Queensland, Australia

Postby ernbuild » Sat Jun 21, 2008 5:12 pm

Winfield RED wrote:I might join you with an Irish Whiskey Panther :D

Might have a medicinal rum myself :o
adventure before dementure

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Sun Jun 29, 2008 9:25 am

Just a update

Got steering rack back and fitted up, now it just refuses to start, anti theft issue, if I could steal it and go for a run I would

about time to get out of vettes there just a pain in the hole, need something I can just get in and drive

User avatar
australi
* Founding Administrator
Posts: 16532
Joined: Sun Jan 15, 2006 8:32 pm
Location: Brisbane, Queensland, AUSTRALIA
Contact:

Postby australi » Sun Jun 29, 2008 9:44 am

Winfield RED wrote:I might join you with an Irish Whiskey Panther :D


Ah bugger it; count me in too fellas! :-D :D

And Kym, 'whatever do you mean'? :)

User avatar
Winfield RED
*Gold Class Member #350
Posts: 5917
Joined: Fri Mar 03, 2006 1:37 am
Location: Just north of Brisbane, AUSTRALIA

Postby Winfield RED » Sun Jun 29, 2008 11:42 am

Panther wrote:about time to get out of vettes there just a pain in the hole, need something I can just get in and drive

Mate ive been thinking the exact same thing for quite some time now...

User avatar
australi
* Founding Administrator
Posts: 16532
Joined: Sun Jan 15, 2006 8:32 pm
Location: Brisbane, Queensland, AUSTRALIA
Contact:

Postby australi » Sun Jun 29, 2008 1:26 pm

(Shhhhh! So have I; for YEARS now)

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Wed Jul 02, 2008 6:40 am

checked all the earths there fine, about to pull the ignition and strip it down for a clean and re adjustment

Colum lock bypass ordered, may even do vats bypass

User avatar
MAXX WRENCH
*Gold Class Member #200
Posts: 1870
Joined: Fri May 05, 2006 5:29 pm
Location: COLORADO..USA

Postby MAXX WRENCH » Wed Jul 02, 2008 6:48 am

VATS BYPASS....SMART MAN...
ONE SHOT ONE KILL I WIN

User avatar
Winfield RED
*Gold Class Member #350
Posts: 5917
Joined: Fri Mar 03, 2006 1:37 am
Location: Just north of Brisbane, AUSTRALIA

Postby Winfield RED » Wed Jul 02, 2008 11:46 am

You can turn VATS off in the PCM programing.

User avatar
Panther
*Gold Class Member #460
Posts: 1166
Joined: Mon Jan 16, 2006 12:07 pm
Location: Marayong, Sydney, Australia

Postby Panther » Sat Jul 05, 2008 7:44 am

Update:

Cleaned all the body earths even tho they were as shinny as, I was checking conections under the dash, there is a 2 White wire plug coming off the front of the ignition, I didn't like the way it was routed, so I tried a couple of different ways till I was happy, bloody car fired straight up and has been doing so ever since, well since yesterday anyway, still intend to do a couple of things before I run around the block

Anyway were up and running and rack dosn't seem to be leaking, touch wood :-)


Return to “Fifth Generation C5 (1997-2004) Technical and Performance”

Who is online

Users browsing this forum: No registered users and 1 guest